Disk error

Benutzer12780  (39)

Verbringt hier viel Zeit
Herzlich Willkommen.. Computerexperten.. :zwinker:

Erstmal ein paar Daten..

AMD 1000 MHz, HD 40 GB, 256 mb DDR Ram..

Betriebsystem WinXP Home

Nachdem ich versuchte WinXP auf der Festplatte einer Freundin zu installieren, kam es zu der Fehlermeldung "Disk error".. Bios erkennt die Festplatte.. Beginnt noch von WinXP-CD zu Booten, so das ich von dort aus im MS-DOS feststellen konnte das mit der Festplatte alles okey ist.. (Hab auf beide Partitionen vollen zugriff..)

Ich komme an diesem "Disk error" nimmer vorbei und kann somit kein Betriebssystem booten.. kann mir jemand helfen?? Kirby, vielleicht weißt Du ja ein Rat.. :anbeten:

Ich habs aber net eilig weil ich nu erstmal zum Weinfest geh, als wer antwortet darf sich Zeit lassen... :zwinker:

Vielen Dank im vorraus... :gluecklic
 

Benutzer2610 

Meistens hier zu finden
1. Du kannst ned einfach dein Windows bei deiner Freundin installieren
2. Ist die Fehlermeldung nicht wirklich aussagekräftig ... ist die komplett?
Wann tritt sie auf?
 

Benutzer18167  (52)

Verbringt hier viel Zeit
Hört sich auf den ersten Blick nach einem Controller Fehler an...

aber wie Kirby sagte/meinte

... ich brauche mehr Detaaaaiiiis

Hat der Rechner ein OS oder willst Du ein neues aufspielen ?

Wenn ja, läuft das 1A ?

gruss
corran
 

Benutzer12780  (39)

Verbringt hier viel Zeit
Die Fehlermeldung tritt exakt auf nachdem die CD-Laufwerke nach Bootfähigen CD`s überprüft wurden.. ungefähr so sieht es dann aus..
_______________________________
Boot from ATAPI CD-ROM : Failure....
disk error
_______________________________

Das WinXP was zuvor drauf war, war zwar noch lauffähig, aber auch schon so zerhackt und vollgestopft mit allen schlechtigkeiten die das Internet so zu bieten hat..

So hab ich die Festplatte nach Datensicherung auf FAT32 formatiert, partitioniert, eine Partition in NTFS formatiert und WinXP drauf "installiert".. (in Anführungszeichen weil es nachdem alle Datein kopiert waren und rebootet wurde folgende Fehlermeldung kam)

<Windows Root> [D:\WINXP\System32\hal.dll] Windows konnte nicht gestartet werden weil die genannte Datei beschädigt ist.. oder so ähnlich..

Ich hab nun mittlerweile rausgefunden das die "Hal.dll" etwas mit ner Hardwareüberprüfung zu tun hat, aber an der Hardware hat sich nichts geändert!?!?!

Naja danach kam dann immer nur noch die Fehlermeldung "Disk error", aber wenn ich dann mit der XP-CD boote und die Reparierkonsole (MS-DOS) aufrufe kann ich einwandfrei auf beide Partitionen zugreifen..

nochmals dankäää :zwinker:
 

Benutzer12780  (39)

Verbringt hier viel Zeit
oki... einen moment, das ham wir gleich... :link: :bier:
 

Benutzer10697 

Verbringt hier viel Zeit
Boot from ATAPI CD-ROM : Failure....
Da du im Dos Modus auf die Platte zugreifen kanns, und die Fehlermeldung sich augenschewinlich nicht auf die HD, sondern auf das CD.DVD-Rom bezieht, solltest du mal im Bios die Bootsequenz kontrollieren und ändern.
Evt. das CD.DVD-Rom mal ganz zum Booten deaktivieren.

Ich hatte letztens ein Mainboard, das sobald ich auf dem sekundären Controller ein LW anschloß, von diesem booten wollte, es war kein booten mehr von HD auf dem primären Controller möglich, egal was ich einstellte (im Bios), aber das wird bei dir nun nicht gleich sein müssen, bei mir war das MB defekt .

Aber ansonsten klemm mal das CD-Rom ganz ab.
Oder nimm die CD raus, die sich darin befindet :cool1:

Edit:
HAL = Hardware Abstraction Layer (oder so ähnlich), Win NT basierte Systeme lassen keinen direkten Zugriff von Programmen auf die Hardware zu, so übernimmt dder HAL die übermittlung/Kommunikation.

Hast du die Festplatte mal intensiv untersucht ?
Könnte der Arbeitsspeicher ne Macke haben ?
 

Benutzer12780  (39)

Verbringt hier viel Zeit
"Boot from ATAPI CD-ROM : Failure.... " kommt daher weil keine Bootfähige CD-Rom im Laufwerk drin hab.. wenn ich jetzt die WinXP CD reinleg dann kommt die Meldung, das ich ne beliebige Taste drücken soll um von CD zu Starten.. wenn ich statt dessen abwarte kommt denoch die Meldung "Disk error" das sieht dann folgendermaßen aus..
________________________________
Boot from ATAPI CD-ROM :
Drücken sie eine beliebige Taste um von CD zu Starten.. (Sinngemäß)
Disk error (nachdem ich ca. 5 Sekunden gewartet habe)
________________________________

und dann bleibt mir nix anderes übrig als ein Neustart..

Wenn ich im BIOS das Booten von CD deaktiviere kommt genau an der Stelle eben sofort die Meldung "Disk error" :rolleyes2

Festplatte hab ich gerade komplett in FAT32 konvertiert und CHKDSK.EXE drüberlaufen lassen.. War alles oki.. naja und der Arbeitsspeicher besteht den Standard-Speichertest ganz zu anfang problemlos.. nebenbei gefragt.. kann ich den auch anders testen??
EDIT: @ Anobach

uiii viel zu lesen.. oki na das hätte es gewesen sein können (iss das noch Deutsch*hihi*) der Disk error iss aber immernoch da.. :cry:
 

Benutzer2610 

Meistens hier zu finden
Habe noch mal nachgelesen. Also Dein Startlaufwerk muß als erstes in NTFS sein
Ähm ... meine Start-/Systempartition ist FAT32 primär. Darauf befinden sind ein Win98 (zum daddeln) und Windows 2000. Hintendran hängen (erweiterte Partition als logische Laufwerke) noch 1x FAT32 und NTFS5.
Würde mich schwer wundern wenn das bei XP nicht ebenso ginge.
 

Benutzer631 

Verbringt hier viel Zeit
meister schrieb:
@Threadstarter:
Ich tippe hier eher auf CD - Fehler oder Probleme mit den Bootfähigkeiten des CD-Roms...

wohl eher nicht.

baerchen schrieb:
Wenn ich im BIOS das Booten von CD deaktiviere kommt genau an der Stelle eben sofort die Meldung "Disk error"


Ne verhunzte WindowsXP Installation macht keinen Spaß....hast du Partitionssoftware oder nimmst du Fdisk, bzw. die Möglichkeit, im Windows Setup die Partitionen zu erstellen?
Jedenfalls würde ich an deiner Stelle die Partition nochmal ordentlich formatieren und die Installation ein zweites Mal versuchen. Klappt dies nicht, hast du wohl Ärger mit dem Arbeitsspeicher oder der Festplatte. Dann bitte mit ner Herstellerdiskette eine Diagnose durchführen. Wenn du keine hast, sag mir bitte die Marke deiner Festplatte.
 

Benutzer12780  (39)

Verbringt hier viel Zeit
LangerJan schrieb:
Ne verhunzte WindowsXP Installation macht keinen Spaß....hast du Partitionssoftware oder nimmst du Fdisk, bzw. die Möglichkeit, im Windows Setup die Partitionen zu erstellen?
Jedenfalls würde ich an deiner Stelle die Partition nochmal ordentlich formatieren und die Installation ein zweites Mal versuchen. Klappt dies nicht, hast du wohl Ärger mit dem Arbeitsspeicher oder der Festplatte. Dann bitte mit ner Herstellerdiskette eine Diagnose durchführen. Wenn du keine hast, sag mir bitte die Marke deiner Festplatte.
Als WinXP noch lief hab ich se mit PartitionMagic aufgeteilt.. nun bin ich begeisterter Fdisk nutzer.. :zwinker: Ich hab jetzt bald alle variationen was das formatieren und partitionieren angeht durchgeführt, WinXP Dateien installiert und immer wieder kommt der "Disk error"

hm.. kann es sein das der Arbeitsspeicher durch die jetzt sehr häufigen Neustarts einen mitbekommen hat?? Nun auf die Festplatte kann ich ja im DOS noch einwandfrei zugreifen (lesen,schreiben usw.)
Herstellerdiskette wird wohl keine dabei sein, aber um trotzdem sicher zu gehn reich ich die Daten morgen nach.. :zwinker:

nochmals vielen Dank.. :schuechte (auch wenn die Hoffung langsam zur neige geht..)
 

Benutzer10697 

Verbringt hier viel Zeit
Versuch mal die Startdateien der Disk auf C: zu übertragen.
"Sys C:" lautet der Befehl dafür (Wenn man auf A: ist).
Somit kann man nach Neustart sehen, ob die Platte übehaubt "noch" startfähig ist.

Dann könntest du, falls du den Arbeitsspeicher im Verdacht hast, die Settings im Bios runtersetzen, also den Speicher langsamer einstellen (z.B. statt cas 2 auf cas 2.5 usw. ).

Hast du mal alle anderen Laufwere physikalisch vom Controller getrennt, also auch die auf dem Sekundären ?
 

Benutzer12780  (39)

Verbringt hier viel Zeit
emotion schrieb:
Versuch mal die Startdateien der Disk auf C: zu übertragen.
Ämm wie finde ich denn raus welches die Startdateien sind oder soll ich die ganze WinXP-CD kopieren?? oder meinst Du jetzt nur (Autoexe.bat und Setup.exe)

Dann könntest du, falls du den Arbeitsspeicher im Verdacht hast, die Settings im Bios runtersetzen, also den Speicher langsamer einstellen (z.B. statt cas 2 auf cas 2.5 usw. )
werd ich morgen mal versuchen..

Hast du mal alle anderen Laufwere physikalisch vom Controller getrennt, also auch die auf dem Sekundären ?
Ja hab ich gemacht.. danach hat er nur noch die Festplatte erkannt.. der "Disk error" kam trotzdem.. :cry:
 
T

Benutzer

Gast
so nu kriegste noch ne Meinung :zwinker:
also ich denke das das Problem nicht die Festplatte ist .. aber um ganz sicher zu gehen kannst du eine low level Formatierung in erwägung ziehen.. würd ich aber als letzes machen...

von was für einer XP cd installierst du einer OEM cd ??? die verursachen bei der Hardware überprüfung fehler da sie imemr nur an eine bestimmte Hardware gebunden sind!
also: versuchs von ner XP pro cd..(NICHT OEM) und deaktiviere erstmal alles andere was du nett brauchst
!achte darauf das du im BIOS die bootreihenfolge so einstellst das er das CD laufwerk vor der HD bootet.
!Und stell im BIOS ein halt on no Errors vielleicht kommste dann ja schon durch..
viel glück :cool1:
 

Benutzer10697 

Verbringt hier viel Zeit
Ich vergass zu bemerken, "sys c:" wird wohl nur bei Dos /win 98 Startdisketten funktionieren.
Sys c: kopiert die zum booten notwendigen Dateien auf das Ziellaufwerk c:.
Also die command.com ...
Autoexec.bat und config.sys sind für die grundlegende bootfunktion nicht notwendig.
 

Benutzer12780  (39)

Verbringt hier viel Zeit
ThommyWild schrieb:
so nu kriegste noch ne Meinung :zwinker:
also ich denke das das Problem nicht die Festplatte ist .. aber um ganz sicher zu gehen kannst du eine low level Formatierung in erwägung ziehen.. würd ich aber als letzes machen...
joa jetzt fehlt nur noch die Microbuchse von der Soundkarte, dann hab ich alles durch..*lach* oki man darf nie den Humor verlieren oder wie war das.. *gg*

Ich vermute das WinXP bei der Installation ne ganze menge mit dem Bios angestellt hat, was aber auch wieder unlogisch wäre, weil irgentwie hats ja auch mit der Erstinstallation geklappt.. es könnte auch am RAM liegen, wegen den zugegebener Maßen "ungeduldigen" Neustarts.. obwohl der Speichertest ja einwandfrei durchläuft.. es kommen auch keine Fehlerbeep-Codes..

ämm low level Formatierung?? macht das denn einen Unterschied?? Das wird doch normalerweise nur vom Hersteller gemacht, daher bin ich da Vorsichtig, sonst schick ich das Teil tatsächlich noch ins Nirvana..

ThommyWild schrieb:
von was für einer XP cd installierst du einer OEM cd ??? die verursachen bei der Hardware überprüfung fehler da sie imemr nur an eine bestimmte Hardware gebunden sind!
also: versuchs von ner XP pro cd..(NICHT OEM) und deaktiviere erstmal alles andere was du nett brauchst
!achte darauf das du im BIOS die bootreihenfolge so einstellst das er das CD laufwerk vor der HD bootet.
!Und stell im BIOS ein halt on no Errors vielleicht kommste dann ja schon durch..
viel glück :cool1:
Ne andere ausser OEM besitze ich nicht.. :schuechte :cry: (Ich glaub ich weiß jetzt wo der Hase im Pfeffer liegt... :link: ) Hat jemand ne ahnung wo ich günstig eine PRO Version erhalten kann??

joa das BIOS ist nun so eingestellt, das CD und Floppy vor HDD-0 bootet und es funktioniert sogar.. *gg* halt on no Errors war bereits voreingestellt.. (hab zwischendurch aber auch auf "All Errors" umgeschaltet, wobei sich aber nichts geändert hat..)

emition schrieb:
Ich vergass zu bemerken, "sys c:" wird wohl nur bei Dos /win 98 Startdisketten funktionieren.
Sys c: kopiert die zum booten notwendigen Dateien auf das Ziellaufwerk c:.
Also die command.com ...
Autoexec.bat und config.sys sind für die grundlegende bootfunktion nicht notwendig.
hm.. ja der Befehl iss net vorhanden.. naja jetzt ist sowieso alles mehrmals formatiert usw. ich kümmere mich jetzt erstmal um eine XP-PRO CD.. vielleicht gibs sowas günstig beim Video-Verleih.. :grin: so zum testen.. *lach*

@LangerJan

Es ist eine Maxtor und ich hab mir jetzt das Diagnoseprogramm von der Homepage gezogen.. mal sehn was passiert.. :zwinker:
 

Benutzer12780  (39)

Verbringt hier viel Zeit
Meister schrieb:
Na denn.... vielleicht ist es aber auch einfach ein Sonnenwind? Schon mal den Rechner in Alufolie gepackt? ;-)
:grin::grin::grin:
*lach* Ich nem immer..
03.jpg


Das ist ein gutes Zeichen und XP macht natürlich _NIX_ im oder am Bios, im Optimalfall ignoriert es den größten Teil der Bios-Informationen sogar.

RAM glaube ich nicht, ist aber möglich.
Na dann hoff ich mal stark das Du recht hast und ausserdem hoffe ich das mein Speicher noch net hinne iss..

Ja, macht einen Unterschied, aber vergiss es. Das hilft Dir hier nicht weiter.

ja ich glaube auch das das net nötig ist, auch wenn ich keinen schimmer davon hab.. :schuechte

Gar nicht. Leider.

Eigentlich Schade.. naja, muss ich mich halt mal umschauen.. vielleicht bekommt der PC-Spezialist um die Ecke ja ein wenig mitleid.. *gg*

Siehst Du den Hinweis zum Taste-Drücken um von CD zu booten? Wenn ja und wenn es dann nicht klappt, steigt die Wahrscheinlichkeit, dass es das CD-Rom ist. XP bootet nicht per virtuellem Diskettenimage und hat andere Anforderungen an das CD-Rom als z.B. 98
Ja den seh ich, wenn ich eine Bootfähige CD reinschmeiß und wenn ich dann ne Taste drück kommt auch kein "Disk error" sondern z.B. das WinXP installations-menü usw..


SYS c: war ein blöder Tip ;-)
Hehe.. also mit fehlerbehebungen bei PC's hab ich schon die mysteriösesten sachen erlebt.. da macht es schon ne menge aus, wenn Dir mal ne schwarze Katze über den Weg läuft.. *lach* Ausserdem weiß ich jetzt das es so net funktioniert und so bin ich ein wenn auch nur kleines Stücken schlauer geworden.. :zwinker:

Okay.... hast Du mal alle Partitionen entfernt?

Kommst Du an eine XP-Kommandozeile oder hast Du eine Dos 6.22 / Win 98 - Boot-Diskette oder Bootfähige CD-Rom? Also ein Bootmittel, dass NICHT XP ist?
Ja das hab ich mal getan.. momentan hab ich quasi wieder den damaligen zustand hergestellt, wo halt noch alles lief.. also C: in NTSF und D: in FAT.. beide Partitionen sind ungefähr gleichgroß..

ämm ich hab mir mit ner laufenden XP-Verson eine DOS (welche Version auch imma es sein mag) Startdiskette erstellt, die auch einwandfrei funzt.. :zwinker: aber es dauert sicherlich net mehr lange bis ich jemanden gefunden habe mit ner PRO Version, die ich dann erstmal versuchen werde zu installieren..
 

Benutzer6487 

Verbringt hier viel Zeit
Ich frage mich momentan, ob das XP überhaupt richtig installiert wurde, oder ob da auch schon große Fehler auftreten. Wenn Xp gar nicht erst installiert ist und der Rechner versucht, was bootbares auf derPlatte zu finden, dann könnte dieser Fehler auftauchen, auch wenn die Meldung nochmalerweise "Ungültiger Datenträger" oder so ähnlich ist.

Dann würde ichmal gucken, ob im BIOS der Virenschutz deaktiviert ist. Der Virenschutz macht den Bootsektor aller PLatten schreibgeschützt, denn früher haben sich viele Viren genau da reingeschrieben, um als aller erstes vor DOS/ Windows/... gestartet zu werden. Wen Win installiert ist, MUSS es natürlich den Bootsektor verändern, damit dort steht, von wo und wie Windows gestartet werden soll.
Der Virenschutz verbirgt sich z.B. hinter "Boot Sector Protection" und sollte für die Installation auf disabled stehen.
 

Benutzer12780  (39)

Verbringt hier viel Zeit
Event Horizon schrieb:
Ich frage mich momentan, ob das XP überhaupt richtig installiert wurde, oder ob da auch schon große Fehler auftreten. Wenn Xp gar nicht erst installiert ist und der Rechner versucht, was bootbares auf derPlatte zu finden, dann könnte dieser Fehler auftauchen, auch wenn die Meldung nochmalerweise "Ungültiger Datenträger" oder so ähnlich ist.
Ja es war schonmal richtig installiert.. der fehler kam erst nach dem versuch einer neuinstallation.. es ging soweit gut wie alle Dateien kopiert waren und der PC versucht hat neuzustarten, doch dann passierte es wie oben beschrieben..

momentan ist kein Bootbares System auf der Platte drauf und es kommt auch jetzt nix anderes mehr, als XP PRO auf die Platte.. :zwinker:

Event Horizon schrieb:
Dann würde ichmal gucken, ob im BIOS der Virenschutz deaktiviert ist. Der Virenschutz macht den Bootsektor aller PLatten schreibgeschützt, denn früher haben sich viele Viren genau da reingeschrieben, um als aller erstes vor DOS/ Windows/... gestartet zu werden. Wen Win installiert ist, MUSS es natürlich den Bootsektor verändern, damit dort steht, von wo und wie Windows gestartet werden soll.
Der Virenschutz verbirgt sich z.B. hinter "Boot Sector Protection" und sollte für die Installation auf disabled stehen.
Nach mehrfacher Formatierung dürfte sich das ohnehin erledigt haben.. es steht aber Standardmäßig auf disabled.. :zwinker:

Meister schrieb:
Tip:
Entferne _alle_ Partitionen. Dann entweder:

Start von Diskette, auf der das Programm FDISK ist. Nach dem Start mit FDISK eine Partition anlegen, die ruhig FAT sein darf. Ändern kannst Du das später jederzeit. Dann CD starten oder:

Direkt XP-Setup von CD booten, das Setup-Programm eine Partition anlegen lassen (muss ja nicht der ganze Speicher sein...), egal ob NTFS oder FAT, aber wenn NTFS bitte nicht "Schnellformatierung" wählen...
Genauso hatte ich es bereits gestern versucht.. daher bin ich nun der "festen" Überzeugung das eine XP PRO Version mir weiterhelfen könnte..

Vielen Lieben Dank Leute...:gluecklic

das Thema ist vorläufig auf Eis gelegt..
1. weil ich mal ne Pause brauch und 2. weil's echt schlaucht.. :rolleyes2
 

Benutzer10697 

Verbringt hier viel Zeit
SYS c: war ein blöder Tip ;-)

:angryfire

Bei dem ganzen Hickhack hier wäre das der erste schnellste Fehlerausschluß den ich kenne.
Sys c: macht die HD minimal bootfähig.
Um zu sehen, ob evt. etwas mit dem Bootsektor/MBR der HD nicht stimmt.

Aber wenn ihr dann lieber komplett mal Win98 installiert, kommt nur auf das selbe raus, im Ergebnis.
 
Oben
Heartbeat
Neue Beiträge
Anmelden
Registrieren